#1 0.6.1 doesn't work with NEC ND-3550A von lal 26.03.2008 14:46

Hello!

According to http://qpxtool.sourceforge.net/supported.html my ND-3550A
should be supported by qpxtool but it doesn't work for me. I'm running Debian 4.0
(Etch) with kernel 2.6.24 and the dvd drive has the latest firmware 1.07 installed.

I compiled the latest qpxtool 0.6.1 without problems but when I run it nothing works.
When I insert a data DVD-R into the drive qpxtool shows random "Total size:" values
on the Media tab (some hundreds GB) allthough the "Readable size:" value is correct.
The only controls that are *not* deactivated are "Detect" on Info tab (but doesnt work,
"Current:" shows random values, "-123x" for example), "C1/C2/CU", "Read transfer
rate", "Commands:", "Scan speed:" and "Run Tests" on Media tab, as well as "Lock
disc" and "Load/Eject". When I "Run tests" it displays a message box "All tests
complete!" after about 10 seconds but absolutely nothing changes (i.e. no grahs).

Console output when starting qpxtool:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
 

root@bender ~# qpxtool
 
________________________________________
QPxTool-0.6.1
(c) 2005-2006, Gennady "ShultZ" Kozlov
________________________________________
current system:
OS name : Linux
release : 2.6.24
version : #1 SMP PREEMPT Thu Jan 31 11:02:55 CET 2008
machine : i686
node : bender
domain : (none)
________________________________________
** creating mainwin
** dinamic objects init...
** Initializing menu bar...
** Read TR graph init...
** Cx/Pi graph init... C1/PIE, C2/PIF, CU
** J/B graph init... Jitter OK, Beta OK
** FE/TE graph init... FE, TE
** TA graph init... OK
** PixMaps init...
** Init scan thread... OK
** Scaning for MMC compliant devices...
/dev/sr0: _NEC DVD_RW ND-3550A 1.07
** Scan complete: 1 device(s) found
 
Selected: /dev/sr0
:-( unable to MODE_SENSE(10) : Input/output error
:-( unable to MODE_SENSE(10) : Input/output error
 
** Reading supported mode pages...
:-( unable to MODE_SENSE(10) : Input/output error
:-( unable to GET_CONFIGURATION LENGTH : Input/output error
:-( unable to MODE_SENSE(10) : Input/output error
** Drive features...
:-( unable to GET_CONFIGURATION LENGTH : Input/output error
Hide CD-R : ---
SingleSession : ---
SpeedRead : ---
PoweRec : ---
GigaRec : ---
Silent mode : ---
SecuRec : ---
VariRec CD : ---
VariRec DVD : ---
DVD+R bitsetting : ---
DVD+R DL bitsetting : ---
DVD+R(W) testwrite : ---
AutoStrategy : ---
PlexEraser : ---
Pioneer Quiet Mode : ---
Disc info length: 0x0020
0x00 0x20 0xA7 0x51 0x00 0x00 0x08 0x00
0x01 0x7C 0x17 0xC5 0xDE 0x86 0xA0 0x6D
0x98 0xD3 0xBE 0xD8 0xB6 0x33 0x8C 0x1B
0xC7 0xF0 0xA2 0x2A 0x2D 0x61 0x6E 0x33
0x70 0x68
first track# on disc: 81
first track# in last session: 5888
last track# in last session: 50440
disc type: 01
disc ID: DE86A06D
Last session lead-in start: 39123:190.216
Last possible lead-out start: 46643:140.27 (sector 0x0C82E19B)
:-( unable to MODE_SENSE(10) : Input/output error
:-( unable to MODE_SENSE(10) : Input/output error
:-( unable to MODE_SENSE(10) : Input/output error
== Detecting supported read speeds...
:-( unable to SET_STREAMING : Input/output error
======
:-( unable to SET_STREAMING : Input/output error
:-( unable to MODE_SENSE(10) : Input/output error
Current Read Speed : 346kB/s (1x CD, 0x DVD)
Disc read capacity: 2139986 sectors/133749 ECC blocks/4179MB/475:33.11MSF
Disc free capacity: 207763891 sectors/12985243 ECC blocks/405788MB/46169:45.16MSF
Total capacity: 209903877 sectors/13118992 ECC blocks/409968MB/46645:18.27MSF
Get CD track list
:-( unable to READ_TOC : Input/output error
Error reading TOC :(
Drive capabilities: 0x80000000
Drive Read capabilities: 0x00000000
Drive Write capabilities: 0x00000000
:-( unable to GET_EVENT_STATUS : Input/output error
** clearing results...
** init done...
** setting main widget
** initializing main window...
:-( unable to GET_EVENT_STATUS : Input/output error
 
 



Last line is repeated indefinitely once a second.

Regards
lal[/code]

#2 RE: 0.6.1 doesn't work with NEC ND-3550A von lal 28.03.2008 17:44

I applied the patch in ft78-qpxtool-fils-to-run-tests-on-fedora-8-2-6-24-3-12.html#299
to qpxtool 0.6.1 and now it works. Thanks to Thomas Maguin who pointed this out to
me in news:de.comp.hardware.laufwerke.brenner.

Xobor Ein Kostenloses Forum von Xobor.de
Einfach ein Forum erstellen
Datenschutz